Device Tree Blob support in l4linux

Martin Schröder martin.schroeder at openlimit.com
Mon Aug 18 19:38:54 CEST 2014


Am 13.08.2014 um 22:40 schrieb Adam Lackorzynski:

>
> So it worked before using DTBs? Some config/setting issue?
>

Yes, both network of my imx28 worked withou DTB. I is some config issue:

After searching a while, I am sure that the Device Tree is not used in 
my configuration at all. As I wrote in an older thread "IO configuration 
language" I am using on the vbus the strings
    "imx28-fec.mydev0" => wrap(hw-root.NIC0)
to get the platform device added in mach_setup.c. This is done by a 
custom handler in the callbacks which captures the "imx28-fec.mydev0" 
and "imx28-fec.mydev1" devices and creates the platform device.
After renaming the device to "imx28-fec" (and thus disabling the private 
callback), I see that the device is still added in a generic way (IRQ, 
MEM, PORT) in copy_platform_device, but without the required additional 
data (Phy Interface Mode). So Ethernet is still probed but due to the 
wring mode not working.

Now I removed the strings from the io configuration. Mach_setup.c is no 
longer adding platform devices and ... Ethernet is no longer probed. I 
also verified that the DTB was loaded, but for some reasons the DTB is 
unfortunately not used or does not match.

I am using the imx28-evk.dts where I replaced the "model" and 
"compatible" line by what I found in simple.dts.

Martin







More information about the l4-hackers mailing list