Doubt about fiasco-l4re on FastModels

Maria Soler m.soler at virtualopensystems.com
Wed Aug 20 18:41:25 CEST 2014


Hello,

I want to have a scenario where fiasco-l4re runs in the secure world
and Linux runs in the non-secure world. For this I am using the
CortexA15x1 model in FastModels. I am using the snapshot 2014053111
for fiasco-l4re. I have already compiled and am able to run
fiasco-l4re in the secure side.

At the moment I am trying to make the example pkg/examples/sys/vm-tz
work (included in the L4 version available at
http://svn.tudos.org/repos/oc/tudos/trunk/), but I have been
unsuccessful so far. I have added the header files that were missing
and have been able to compile the example but it fails when I execute
it. Has any of you tried to run this example on FastModels? Do you
have any ideas why it may fail? It fails both when running the version
of fiasco-l4re where it originally appears (with "terminate called
after throwing an instance of 'N2L413Runtime_errorE'") and also in the
latest version (with "L4Re[rm]: unhandled write page fault @0
pc=100b868").

Also I would like to know why this example is not included in more
recent versions of fiasco-l4re. I am particularly interested in
fiasco-l4re running on TrustZone in secure mode and something else
running in the non secure mode. I would like to know if there is any
other example that does something similar and is more recent (and
works on FastModels, ideally) or if there is a better way to do this.

Thank you very much for your help,
María.



More information about the l4-hackers mailing list