GPIO Interrupt on L4Linux

Adam Lackorzynski adam at os.inf.tu-dresden.de
Thu Aug 28 00:37:13 CEST 2014


On Tue Aug 26, 2014 at 23:04:41 +0300, Yunchuan Geng wrote:
> I am implementing a driver using GPIO input as interrupt.  When setup
> handler for gpio, either from "irq_set_chained_handler()" or "requst_irq()"
> in kernel driver, it finally calls "l4lx_irq_io_startup()" function and
> return "/l4x-irq: Failed to set type for IRQ x".//
> /
> What this error means?
> 
> Right before this error, it called l4_icu_set_mode() which goes to l4 side,
> I tried to print out debug information in l4 side, but not very successful.
> 
> I tried read document about ICU and IRQ handling library about L4Re, but did
> not find the answer, maybe I overlook it. So I ask help here.
> Is there an guidance about this interrupt things or could some one please
> give me some advice.

In the IO configuration you use for L4Linux, is the interrupt number for
the GPIO controller listed? That is, is the GPIO controller working? And
do I understand correctly that you are trying to use an interrupt for a
specific GPIO pin?



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list