Run and debug Fiasco.OC kernel and L4Re using a DSTREAM JTAG device and the ARM DS-5 IDE

Adam Lackorzynski adam at os.inf.tu-dresden.de
Mon Nov 17 23:53:11 CET 2014


Hi,

On Mon Nov 17, 2014 at 11:39:06 +0100, Mahdi Aichouch wrote:
> I didn't tried yet using an SD card or tftp.
> I am interested in testing it using tftp, is there any guide showing how to
> setup a working configuration on my development machine?

There should be quite a few out there. In short: You need a tftpserver
on some other system. Then use in u-boot (for example):
dhcp; tftpboot 0x11000000 /path/to/bootstrap.raw; go 0x11000000

Do not use a gigabit switch, just 100M, at least it made a difference
between not working and working for me.

> I compiled the kernel using this command line:
> $> make BOOTSTRAP_NO_STRIP=y PLATFORM_UART_NR=1
> 
> Now the debugger is not complaining. I have the debug information and I can
> also see the source code (as shown in the attached screenshot).

It is sitting in the pl011 UART driver. Now that's the wrong one.
Looks like wrong platform. Better with:
  make BOOTSTRAP_NO_STRIP=y PLATFORM_TYPE=imx6
?
The platform type can also be set in the l4re config, or put
PLATFORM_TYPE=imx6 into l4/conf/Makeconf.boot.

> But I still not get the debug information from the kernel in the minicom
> serial terminal.
> I did a step by step walk through the code, the attached file shows all the
> debug information that I get.
> 
> Do I used the PLATFORM_UART_NR=1 option correctly, what verification should
> I do also?

PLATFORM_UART_NR=1 might still be valid depending on which UART is used.



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list