Running l4android on cubieboard2

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Jan 13 23:44:42 CET 2015


Hi,

On Tue Jan 13, 2015 at 11:41:29 +0100, cem akpolat wrote:
> I updated the uboot source code, somehow it started to work even though the
> version number is the same. Now, I can see that l4linux is loaded, but then
> an internal error is raised "Internal error: Boom!: 90000007 [#1] ARM".
> This occurs after a page fault message. it seems that it is like memory
> corruption, in other words RAM is seen that is not configured properly. Is
> that related to the address that we give in the module.list. Because I
> changed nothing here. The address is start from "modaddr 0x01100000" and
> the ARM modules as below:

You are using a recent Fiasco.OC version? Your Linux is 3.6 which is
relatively old. We had to change some interface internals which also
required an update to L4Linux. Does the current version of L4Linux work?

> l4linux | Linux version 3.6.0-l4-g485c55d (akpolat at akpolatX240) (gcc
> version 4.7.3 (Ubuntu/Linaro 4.7.3-12ubuntu1) ) #1 Fri Aug 1 18:21:36 CEST
> 2014


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list