Running l4android on cubieboard2

cem akpolat akpolatcem at gmail.com
Mon Jan 19 18:56:59 CET 2015


Hi,

I encountered new failure, by the way I tested with hello word application.
It works fine. I couldn't fine an explanation related  "sh Not tainted".
There are of course some general definitions, but with them I cannot find
the missing part here. Additionally I want to ask, the booting parameters
in uboot and the parameters in l4lx.cfg are evaluated together or l4lx.cfg
booting parameters ignores the uboot booting parameters.
===========

Freeing unused kernel memory: 116K (02306000 - 02323000)
Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b

CPU: 0 PID: 1 Comm: sh Not tainted 3.16.0-l4-svn50 #2
[<0200c198>] (unwind_backtrace) from [<020054e8>] (show_stack+0x10/0x14)
[<020054e8>] (show_stack) from [<0223dbe4>] (panic+0x7c/0x1e0)
[<0223dbe4>] (panic) from [<02018ce0>] (do_exit+0x708/0x7a0)
[<02018ce0>] (do_exit) from [<02018e44>] (do_group_exit+0x3c/0x9c)
[<02018e44>] (do_group_exit) from [<020229c8>]
(get_signal_to_deliver+0x148/0x490)
[<020229c8>] (get_signal_to_deliver) from [<02006a30>]
(do_signal+0x114/0x448)
[<02006a30>] (do_signal) from [<02009b14>] (l4x_vcpu_entry_c+0x934/0x1b18)
[<02009b14>] (l4x_vcpu_entry_c) from [<000ea560>] (0xea560)
---[ end Kernel panic - not syncing: Attempted to kill init!
exitcode=0x0000000b

panic: going to sleep forever, bye
l4linux | panic: going to sleep forever, bye


==========
Thanks,
Cem



Cem Akpolat

On Wed, Jan 14, 2015 at 1:02 PM, cem akpolat <akpolatcem at gmail.com> wrote:

> Hi Adam,
>
> ​As you mentioned, I updated the source code and recompiled everything now
> another issue apperad: "l4linux | Copro10/11 access (FPU), invalid, oops".
> This failure is solved by disabling CONFIG_VFP, which is already discussed
> here [1]. I could not forsee the future effect of disabling this attribute
> in the kernel configuration. The current issue is related to the ramdisk.
> In the COMPILATION 2 you can see the outputs. I wanted to use ramdisk, but
> it couldn't work, do you have any idea
>
>
> REF:
> http://os.inf.tu-dresden.de/pipermail/l4-hackers/2014/006169.html
> ================================ COMPILATION 2
> ================================
> 4timer: Using IRQ210
> sched_clock: 64 bits at 1000kHz, resolution 1000ns, wraps every
> 2147483648000ns
> Console: colour dummy device 80x30
> console [ttyLv0] enabled
> Calibrating delay loop... 1908.73 BogoMIPS (lpj=9543680)
> pid_max: default: 32768 minimum: 301
> Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
> Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
> CPU: Testing write buffer coherency: ok
> Setting up static identity map for 0x223f0a8 - 0x223f0a8
> NET: Registered protocol family 16
> DMA: preallocated 256 KiB pool for atomic coherent allocations
> Added static device 'L4ICU' with 0 resources.
> Added static device 'NIC' with 2 resources.
> Failed to create "l4x" debugfs directory: 1
> Switched to clocksource l4kipclk
> NET: Registered protocol family 2
> TCP established hash table entries: 4096 (order: 2, 16384 bytes)
> TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
> TCP: Hash tables configured (established 4096 bind 4096)
> TCP: reno registered
> UDP hash table entries: 256 (order: 0, 4096 bytes)
> UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
> NET: Registered protocol family 1
> Trying to unpack rootfs image as initramfs...
> rootfs image is not initramfs (junk in compressed archive); looks like an
> initrd
> INITRD: Freeing memory.
> l4x: Checks passed.
> NetWinder Floating Point Emulator V0.97 (double precision)
> futex hash table entries: 256 (order: -1, 3072 bytes)
> msgmni has been set to 506
> io scheduler noop registered
> io scheduler deadline registered
> io scheduler cfq registered (default)
> L4 serial driver
> ttyLv0 at MMIO 0x1 (irq = 211, base_baud = 230400) is a L4
> l4ser_shm: L4 shared mem serial driver
> l4cdds: No name given, not starting.
> brd: module loaded
> l4bdds: No name given, not starting.
> mousedev: PS/2 mouse device common for all mice
> TCP: cubic registered
> NET: Registered protocol family 17
> RAMDISK: ext2 filesystem found at block 0
> RAMDISK: Loading 3072KiB [1 disk] into ram disk... done.
> EXT4-fs (ram0): couldn't mount as ext3 due to feature incompatibilities
> EXT4-fs (ram0): mounting ext2 file system using the ext4 subsystem
> EXT4-fs (ram0): mounted filesystem without journal. Opts: (null)
> VFS: Mounted root (ext2 filesystem) readonly on device 1:0.
> Freeing unused kernel memory: 112K (02301000 - 0231d000)
> Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
>
>
> ================================ COMPILATION 1
> ================================
>
> Booting Linux on physical CPU 0x0
> Linux version 3.16.0-l4-g5d0896b (akpolat at akpolatX240) (gcc version 4.7.3
> (Ubuntu/Linaro 4.7.3-12ubuntu1) ) #3 Wed Jan 14 12:22:32 CET 2015
> CPU: Fiasco [410fc074] revision 4 (ARMv7), cr=00000000
> CPU: PIPT / VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
> Machine: L4
> Ignoring unrecognised tag 0x00000000
> Memory policy: Data cache uncached
> CPU: All CPU(s) started in SVC mode.
> INITRD: 00002000 - 00302000
> Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65977
> Kernel command line: mem=256M console=ttyLv0 l4x_rd=rom/ramdisk-arm.rd
> root=1:0 ramdisk_size=10000
> PID hash table entries: 2048 (order: 1, 8192 bytes)
> Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
> Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
> Memory: 259580K/266244K available (2415K kernel code, 137K rwdata, 684K
> rodata, 116K init, 535K bss, 6664K reserved)
> ....
> sched_clock: 64 bits at 1000kHz, resolution 1000ns, wraps every
> 2147483648000ns
> Console: colour dummy device 80x30
> console [ttyLv0] enabled
> Calibrating delay loop... 1908.73 BogoMIPS (lpj=9543680)
> pid_max: default: 32768 minimum: 301
> Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
> Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
> CPU: Testing write buffer coherency: ok
> Setting up static identity map for 0x22449c8 - 0x22449c8
> l4linux | Copro10/11 access (FPU), invalid, will oops
> Internal error: Oops - undefined instruction: 0 [#1] ARM
> Modules linked in:
> CPU: 0 PID: 1 Comm: swapper Not tainted 3.16.0-l4-g5d0896b #3
> task: 11c19ac0 ti: 11c26000 task.ti: 11c26000
> PC is at l4x_fmrx+0x60/0xa4
> LR is at vfp_init+0x38/0x180
> pc : [<020028fc>]    lr : [<0230da10>]    psr: 80000013
> sp : 11c27ed8  ip : 00000000  fp : 00000000
> r10: 11c26000  r9 : 00000000  r8 : 0230d9d8
> r7 : 0234e000  r6 : 11c4fc00  r5 : 02332410  r4 : 02330b48
> r3 : 0230db58  r2 : 00000004  r1 : 00000000  r0 : 00000000
> vcpu: b3000c00  vcpu-state: 00000000
> Flags: Nzcv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment kernel
> Process swapper (pid: 1, stack limit = 0x11c26238)
> Stack: (0x11c27ed8 to 0x11c28000)
>
> ...
> ---[ end trace 49f8e7384a258bd9 ]---
> Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
>
> ---[ end Kernel panic - not syncing: Attempted to kill init!
> exitcode=0x0000000b
>
> panic: going to sleep forever, bye
> l4linux | panic: going to sleep forever, bye
>
>
> ===============================
> Sincerely,
> Cem
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20150119/c13d4221/attachment.html>


More information about the l4-hackers mailing list