[Out-Of-Topic]How to Access Input GPIO of OMAP4460 without L4Re (direct access)

Erry Pradana Darajati pradana.erry at gmail.com
Tue Jan 27 16:19:15 CET 2015

Hi L4 Hackers,
My subject seems out of topic, but i don't know where i can ask this kind
of thing, and i think there are many people have a knowledge about this
I have a problem. I want to directly access GPIO140 (in GPIO5 ball) as
I have a function to print the value of GPIO5_DATAIN (0x4805 B138). But
when i print that out, the value of it still not changed (zero value). I
Conclude, the pin still not accepting the input. I have already done these
things :

1. Set GPIO5_OE to 0x1
2. See the value of MCSPI1_CS3 Pad Configuration (0x4A10 013C) and it give
me value like this (0x011B 001B) which is for GPIO_140 ->
MUX_MODE=gpio_140. PULLUDENABLE=0x1(enable). PULLTYPESELECT=0x1(enable).

Which is in my current knowledge, is a right setting for accepting input.
But still, it's still not successful
So where or what did i miss ? is it still any configuration / address to
set ?

I appologize for the Out-of-Topic Subject .Thank you for any answer and
suggestion and help.

*Erry Pradana Darajati | Student of Computer Engineering*
*Politeknik Elektronika Negeri Surabaya / EEPIS, Indonesia*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20150127/14838489/attachment.html>

More information about the l4-hackers mailing list