[Out-Of-Topic]How to Access Input GPIO of OMAP4460 without L4Re (direct access)

Martin Schröder martin.schroeder at openlimit.com
Tue Jan 27 17:13:28 CET 2015


Am 27.01.2015 um 16:19 schrieb Erry Pradana Darajati:
> Hi L4 Hackers,
> My subject seems out of topic, but i don't know where i can ask this kind of thing, and i think there are many people have a
> knowledge about this subject.
> I have a problem. I want to directly access GPIO140 (in GPIO5 ball) as input.
> I have a function to print the value of GPIO5_DATAIN (0x4805 B138). But when i print that out, the value of it still not changed
> (zero value). I Conclude, the pin still not accepting the input. I have already done these things :
>
> 1. Set GPIO5_OE to 0x1
> 2. See the value of MCSPI1_CS3 Pad Configuration (0x4A10 013C) and it give me value like this (0x011B 001B) which is for GPIO_140 ->
> MUX_MODE=gpio_140. PULLUDENABLE=0x1(enable). PULLTYPESELECT=0x1(enable).
>
> Which is in my current knowledge, is a right setting for accepting input. But still, it's still not successful
> So where or what did i miss ? is it still any configuration / address to set ?
>
> I appologize for the Out-of-Topic Subject .Thank you for any answer and suggestion and help.

I would suggest as a first step doing this from U-Boot to get familar with the GPIOs. The commands are mw.l for writing and mr.l for 
reading. If this works then you can continue with your application and L4.

Martin




More information about the l4-hackers mailing list