l4linux boot failed

Adam Lackorzynski adam at os.inf.tu-dresden.de
Sat Jan 31 00:43:16 CET 2015


On Fri Jan 30, 2015 at 12:32:50 +0100, Nicolas VARONA wrote:
> I want to run the l4linux given in l4re-snapshot-2014092821. So, I built
> the fiasco and the l4re. I created an iso image with grub2 and the
> modules given in example (entry l4linux) as test:
> 
> make grub2iso E=L4linux MODULES_LIST=$cwd/l4/conf/modules.list
> MODULE_SEARCH_PATH=$cwd/kernel/fiasco/mybuild 
> qemu-system-i386 -m 512M -cdrom l4linux.iso -serial file:$cwd/log
> 
> I enabled needed options such as the VPCI bus and followed the
> instructions given in mails approaching my problem
> (http://os.inf.tu-dresden.de/pipermail/l4-hackers/2013/005938.html and
> http://os.inf.tu-dresden.de/pipermail/l4-hackers/2011/004861.html ). I
> can launch Linux but the boot crashes. 
> 
> I also tried with VBUS and modaddr 0x02000000 with the same result. So I
> put the logs in a file. I tried unsuccessfully to see my mistake. 
> 
> In addition, are the last warnings a problem? 
> 
> I give to you the log file, the module list, and the l4lx-gfx.cfg used
> in modules. 
> 
> 
> [33ml4linux | Invalid IO-Port access at pc = 0081c97a port=0x110[0m
> 
> [33ml4linux | Die message: Trap: 13[0m

This is the problem here. The L4Linux is trying to access port 0x110 but
does not have the right to do so. Question is now which driver/subsystem
is doing this so it can be disabled. Boot with initcall_debug=1 to hopefully
see which driver it is and disable it in the config.
Alternatively you should just start with a standard defconfig (x86-ux_defconfig
or x86-native_defconfig).



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list