Problem Launching L4Linux

Adam Lackorzynski adam at os.inf.tu-dresden.de
Sat Jan 31 00:48:28 CET 2015


On Fri Jan 30, 2015 at 12:54:52 +0100, Piwe li wrote:
> I am actually trying to launch L4Linux on Fiasco.OC+L4RE on Xilinx Zynq
> using QEMU but I get an error at the end of the boot of L4Linux :
> 
> */bin/sh: can't access tty; job control turned off*

This is a standard message when launching the shell with init=/bin/sh,
it's not L4Linux specific.

> */ #*
> 
> 
> 
> Even if I have a shell prompt I can’t type anything, that’s why I am
> sending this email.

Does pressing ESC get you into Fiasco's jdb?

Otherwise the configs do not show me anything obvious wrong right now.


> I am aware that my problem is very similar to this one
> http://os.inf.tu-dresden.de/pipermail/l4-hackers/2013/005920.html but I
> tried every solution you suggested.
> 
> 
> 
> I am working under *Ubuntu 64bits 14.04* and I am compiling with
> *arm-linux-gnueabi-gcc
> 4.7.3*.
> 
> To emulate the *Xilinx Zynq*, I’m using *QEMU emulator version 2.0.50*
> configured this way :
> 
> *./configure --target-list="arm-softmmu,microblazeel-softmmu" --enable-fdt
> --disable-kvm*
> 
> To launch QEMU, here is my command line :
> 
> *qemu-system-arm -M arm-generic-fdt -dtb ~/Documents/zynq-zc706.dtb -kernel
> ~/Documents/gitL4/l4-hypervisor/build/l4/images/bootstrap.elf -serial
> mon:stdio*
> 
> Zynq is ARM  so I’m using this ramdisk :
> http://os.inf.tu-dresden.de/download/ramdisk-arm.rd
> 
> You can find below my serial output, my modules.list file and my l4lx.cfg
> file.


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list