Problem with Socket program

Matthias Lange matthias.lange at kernkonzept.com
Sun Feb 1 09:33:04 CET 2015


Hi,

On 02/01/2015 08:47 AM, Gayathri Nagarajan wrote:
> I am trying to execute a socket program like - client server.
> 
> I am getting errors like "undefined reference to socket". But I have
> included <sys/socket.h>. I tried adding library "-lsocket", still the
> same error. Also, I get errors like "Library Dependencies missing",
> "Cflags dependencies missing".
> 
> What libraries have to be added in the makefile for any socket program?
> The kernel implementation of socket is also available in uclibc pkg of
> l4re. 
> How do I make my program linked to the socket call? 

Although you didn't mentioned it, I assume you are trying to run this as
a native L4Re application. Please refer to the mailing list archive [1]
as this question has been raised over and over again over the course of
the last weeks.

TLDR; L4Re does not natively support sockets!

Matthias.

[1] http://os.inf.tu-dresden.de/pipermail/l4-hackers/

> 
> Please help us resolve this error to get the program built successfully.
> 
> Thank you very much
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> l4-hackers mailing list
> l4-hackers at os.inf.tu-dresden.de
> http://os.inf.tu-dresden.de/mailman/listinfo/l4-hackers
> 


-- 
Matthias Lange, matthias.lange at kernkonzept.com, +49 - 351 - 41 88 86 14

Kernkonzept GmbH.  Sitz: Dresden.  Amtsgericht Dresden, HRB 31129.
Geschäftsführer: Dr.-Ing. Michael Hohmuth




More information about the l4-hackers mailing list