Problem Launching L4Linux

Piwe li piweli75 at gmail.com
Tue Feb 10 17:02:49 CET 2015


Hi,

Thank you for your answer Adam.

Nothing happens when I press ESC. I also tried to send ESC with the QEMU
monitor using "sendkey esc" which has also no effect.

Same thing with the Hello World.

I really don't know what could cause this problem but I think it may have
something to do with capabilities (just a guess).

I have to say that my QEMU works fine, I tested it with another Linux. My
.dtb is good too.

Do you have any ideas or suggestions ?

I was also wondering about the "libio: Warning: Query of 'vbus' failed!"
during the boot of L4Linux. I don't think it is a problem (due to the fact
that I'm not using any IPC) but I'm not sure.

Thank you for all the help,

Louis.

-----------------------------------------------------------------

> I am actually trying to launch L4Linux on Fiasco.OC+L4RE on Xilinx Zynq
> using QEMU but I get an error at the end of the boot of L4Linux :
>
> */bin/sh: can't access tty; job control turned off*

This is a standard message when launching the shell with init=/bin/sh,
it's not L4Linux specific.

> */ #*
>
>
>
> Even if I have a shell prompt I can?t type anything, that?s why I am
> sending this email.

Does pressing ESC get you into Fiasco's jdb?

Otherwise the configs do not show me anything obvious wrong right now.


> I am aware that my problem is very similar to this one
> http://os.inf.tu-dresden.de/pipermail/l4-hackers/2013/005920.html but I
> tried every solution you suggested.
>
>
>
> I am working under *Ubuntu 64bits 14.04* and I am compiling with
> *arm-linux-gnueabi-gcc
> 4.7.3*.
>
> To emulate the *Xilinx Zynq*, I?m using *QEMU emulator version 2.0.50*
> configured this way :
>
> *./configure --target-list="arm-softmmu,microblazeel-softmmu" --enable-fdt
> --disable-kvm*
>
> To launch QEMU, here is my command line :
>
> *qemu-system-arm -M arm-generic-fdt -dtb ~/Documents/zynq-zc706.dtb
-kernel
> ~/Documents/gitL4/l4-hypervisor/build/l4/images/bootstrap.elf -serial
> mon:stdio*
>
> Zynq is ARM  so I?m using this ramdisk :
> http://os.inf.tu-dresden.de/download/ramdisk-arm.rd
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20150210/ca9ff7f2/attachment.html>


More information about the l4-hackers mailing list