ARM with Qemu

Adam Lackorzynski adam at os.inf.tu-dresden.de
Mon Mar 16 00:20:36 CET 2015


Hi,

On Wed Mar 11, 2015 at 15:59:09 +0100, Nicolas VARONA wrote:
> >  It segfaults when executing init. One common reason is that VFP
> support is missing in Linux. Strike?
> 
> Sorry for answering so late, but I am still looking if it's a problem of
> the board's hardware configuration. Nonetheless, when I told you the
> panic, I had already enabled the VFP this way:
> [...]
> #
> # At least one emulation must be selected
> #
> CONFIG_FPE_NWFPE=y
> # CONFIG_FPE_NWFPE_XP is not set
> # CONFIG_FPE_FASTFPE is not set
> CONFIG_VFP=y
> CONFIG_VFPv3=y
> CONFIG_NEON=y
> # CONFIG_KERNEL_MODE_NEON is not set (no change even if it's set or not)
>  
> Is that correct or do I forget something? I am wondering something: Does

This looks ok. So it's something different.

> l4linux automatically enable FPU on the board's boot when it's enabled
> in the l4linux configuration? 

FPU support also needs to be enabled in Fiasco. I suppose it is?
Which ramdisk are you using?

> > I think I found it. A hacky fix/workaround is to add the following
> line to >the beginning of >out_char() in src/lib/uart/uart_cadence.cc:
> >     _regs->write<unsigned>(ISR, IXR_RXOVR);
> 
> Thanks for your help and great work! This was the problem. I have added
> the line and compiled the Fiasco: 
> Ned says: Hi World!
> Ned: loading file: 'rom/hello.cfg'
> Press some key: l
> Your input: l (108)
> Enter a number: 
> 4
> Your number is: 4
> 
> The l4 bare metal application works. Nonetheless I tried to compile the
> l4linux with the change in the fiasco and I have still no input in Qemu.
> Is it the same issue for l4linux?

Do you have the 'log = L4.Env.log' statement in the script for launching
L4Linux? What is Linux telling us about ttyLv0? Do not start anything
else which uses 'log = L4.Env.log'.



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list