ARM with Qemu

Adam Lackorzynski adam at os.inf.tu-dresden.de
Thu Mar 19 23:47:08 CET 2015


Hi,

On Wed Mar 18, 2015 at 10:26:46 +0100, Nicolas VARONA wrote:
> >Other issue could be a missing CONFIG_AEABI.
> 
> Thanks for your reply and your time. Nonetheless the CONFIG_AEABI is enabled in L4linux:

Ok. Lets look deeper. Fiasco's debugger has a tracebuffer, we'll use it
to find out more. Please make sure 'extended logging' is enabled in
Fiasco's config. Then, before it happens, enter the jdb, shift-O will
show a selection menu. Enable 'VCPU events' (via return). Let it run
further (via 'g'). Then, enter jdb again, shift-T will show up the
tracebuffer, latest entry is on the top. What do we see?

> >But I suppose you tried that already?
> 
> I have already tried the configuration file this way with the same result (I can reach the end of the boot but I have no input and I can enter into the jdb in Qemu).

Hmm, maybe lets first look at the segfault, maybe it's related but
probably not.



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list