Booting error in L4android for Exynos 5250.

Adam Lackorzynski adam at os.inf.tu-dresden.de
Mon May 18 00:04:56 CEST 2015


On Wed May 13, 2015 at 22:23:18 +0800, Youren Shen wrote:
> I'm trying to booting L4Android in Exynos 5250 platform. I got some
> questions. If anyone can give me any direction or document, It will be very
> helpful.
> 
> 1, How to edit this vbus and devs file to match my platform?
> For example, if I want replace the MOUSE in vbus with TOUCHSCREEN, what
> should I write to determine the driver of the touchscreen, and the register
> address of the driver?
> It seems the .hid can assign the driver? And the MMio can remap the address
> of the IO for driver?

A vbus defines the resources (IRQs and MMIO) for a whole client, i.e.
it's not per driver but per client (e.g. L4Linux). For the touchscreen
you need to give the MMIO regions and IRQs that the touchscreen driver
is using.

> 2, As for GUI driver, what the mag and fb-drv do ? Should I write one

The fb-drv is the framebuffer driver, i.e. the driver that maps some
memory in such a way to the framebuffer hardware that something appears
on the screen. mag is a small window manager that makes multiple
windows, that you can drag around, out of the single hardware
framebuffer.

> driver in L4RE or I can reuse the driver in Linux?

Reusing the driver from L4Linux is possible but typically framebuffer
drivers are reasonable small to be implemented standalone.

> *For this two question I just need some guide*, I can't find details
> explanation of the file or tutorial in Wiki page.
> 
> Thank you very much!
> 
> Also I got some new error when booting. The system mount failed. Would you
> mind to take a look?
> 
> RAMDISK: Loading 1024KiB [1 disk] into ram disk... done.
> 
> EXT4-fs (ram0): couldn't mount as ext3 due to feature incompatibilities
> 
> EXT4-fs (ram0): mounting ext2 file system using the ext4 subsystem
> 
> EXT4-fs warning (device ram0): ext4_update_dynamic_rev:701: updating to rev
> 1 bd
> EXT4-fs (ram0): mounted filesystem without journal. Opts: (null)
> 
> VFS: Mounted root (ext2 filesystem) on device 1:0.
> 
> Freeing unused kernel memory: 164K (02356000 - 0237f000)
> 
> init: cannot open '/initlogo.rle'
> 
> EXT4-fs (ram0): re-mounted. Opts: (null)
> 
> init: Unable to open persistent property directory /data/property errno: 2
> 
> init (1): /proc/1/oom_adj is deprecated, please use /proc/1/oom_score_adj
> inste.
> init: cannot find '/system/bin/servicemanager', disabling 'servicemanager'
> init: cannot find '/system/bin/vold', disabling 'vold'

Looks like the system partition could not be mounted. Where should it
be?



Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list