Problem in final step

Vlad Sof vladimirsofroniev1 at yahoo.com
Wed Jul 15 15:14:39 CEST 2015


Hi guys,
So, I'm having a problem with the final step in booting and running the Fiasco.OC.I've gone through the building steps on L4Re -- The L4 Runtime Environment
|   |
|   |   |   |   |   |
| L4Re -- The L4 Runtime EnvironmentThe L4 Runtime Environment: informations and more |
|  |
| View on os.inf.tu-dresden.de | Preview by Yahoo |
|  |
|   |

 and The Fiasco microkernel - Building and Using
|   |
|   |  |   |   |   |   |   |
| The Fiasco microkernel - Building and UsingThe Fiasco microkernel: prerequisites, compilation, booting |
|  |
| View on os.inf.tu-dresden.de | Preview by Yahoo |
|  |
|   |

When I try "make grub2iso E=hello MODULE_SEARCH_PATH=~/projects/src/kernel/fiasco/mybuild"
I get the following error:
make[1]: Entering Directory `/home/johng/projects/src/l4'Processing entry 'hello'Could not find 'bootstrap' with path '/home/johng/projects/src/kernel/fiasco/mybuild:/home/johng/projects/src/l4/mybuild/bin/x86_586:/home/johng/projects/src/l4/mybuild/bin/x86_586/l4f:/home/johng/projects/src/l4/mybuild/lib/x86_586:/home/johng/projects/src/l4/mybuild/lib/x86_586/l4f'make[1]: *** [grub2iso] Error 1make[1]: Leaving directory `/home/johng/projects/src/l4'make: *** [grub2iso] Error 2
A brief explanation: I'm running Ubuntu 14.04.1 as a virtualmachine guest on a Mac OSX host.I've configured l4re with : Target Architecture: x86-32 architecture CPU variant: 586 type CPUPlatform Selection: PC 
On the fiasco kernel configuration I just saved it without changing any of the settings.
I've been trying to get this work for the past week and I don't know where I'm going wrong. I've followed all the steps up to this point, but for some reason this last step just wont work. Please help ! 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20150715/5075e8a2/attachment.html>


More information about the l4-hackers mailing list