l4linux building error

Adam Lackorzynski adam at os.inf.tu-dresden.de
Mon Sep 21 23:44:54 CEST 2015


On Mon Sep 21, 2015 at 12:27:54 +0000, Shabnam Engineer wrote:
> Hi l4-hackersIn bulding l4linux , I got an error :************************************************************the command : 
>                     make O=/tmp/buildpath L4ARCH=arm CROSS_COMPILE=arm-linux-
> the error : 
> 
>             make[1]: Entering directory `/tmp/buildpath'
>             Package libio-io was not found in the pkg-config search path.
>             Perhaps you should add the directory containing `libio-io.pc'
>             to the PKG_CONFIG_PATH environment variable
>             Package 'libio-io', required by 'libio', not found
>             Getting required compilation flags failed.
>             L4OBJ: /home/shabnam/Desktop/l4re-core-2014092821/src/l4/builddir/
>             L4_REQUIRED_MODS: libc_be_minimal_log_io libc_minimal libc_minimal_l4re libsupc++_minimal log l4re_c-util             libio  libvcpu shmc
>             /home/shabnam/Desktop/snapshot/l4re-snapshot-2014092821/src/l4linux/arch/l4/Makefile:361: *** Aborting..  Stop.
>             make: *** [sub-make] Error 2
> *************************************************************thank you for considering my questionRegards, 

On your system, is there the file
/home/shabnam/Desktop/l4re-core-2014092821/src/l4/builddir/pc/libio-io.pc ?

If no, did a 'make' in directory
/home/shabnam/Desktop/l4re-core-2014092821/src/l4/builddir
ran to a successful end prior to building L4Linux?


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list