Booting L4Linux on Raspberry Pi 2

Adam Lackorzynski adam at os.inf.tu-dresden.de
Thu Mar 10 00:27:50 CET 2016


On Wed Mar 09, 2016 at 17:25:25 +0100, Antoine DEBUT wrote:
> Since I was able to correctly set up my l4re for the Raspberry Pi 2
> thanks to Adam, I did a bunch of tests on the board with custom
> programs and following the examples on the l4/pkg/examples directory.
> 
> Therefore, I am now struggling with the ultimate test: booting and
> using L4Linux.
> 
> I am trying to boot a vanilla L4Linux, using the entry 'L4Linux-basic'
> given in the default modules.list.

But you configured L4Linux yourself? Because that just looks like a
Linux config issue.

> Upon booting, L4Linux delivers this error :
> 

You snipped a few too many lines here, the lines above that would also
be useful.

> [...]
> l4linux | List of all partitions:
> l4linux | 0100            4000 ram0  (driver?)
> l4linux | 0101            4000 ram1  (driver?)
> l4linux | 0102            4000 ram2  (driver?)
> l4linux | 0103            4000 ram3  (driver?)
> l4linux | 0104            4000 ram4  (driver?)
> l4linux | 0105            4000 ram5  (driver?)
> l4linux | 0106            4000 ram6  (driver?)
> l4linux | 0107            4000 ram7  (driver?)
> l4linux | 0108            4000 ram8  (driver?)
> l4linux | 0109            4000 ram9  (driver?)
> l4linux | 010a            4000 ram10  (driver?)
> l4linux | 010b            4000 ram11  (driver?)
> l4linux | 010c            4000 ram12  (driver?)
> l4linux | 010d            4000 ram13  (driver?)
> l4linux | 010e            4000 ram14  (driver?)
> l4linux | 010f            4000 ram15  (driver?)
> l4linux | No filesystem could mount root, tried:  ext3 ext2 ext4 cramfs
> l4linux | Kernel panic - not syncing: VFS: Unable to mount root fs on
> 
> I cannot find any related mail on this mailing list, and therefore must
> ask you for some help.
> Could this be a partition misconfiguration ? Or is it related to
> the '(driver?)' warning on the partition list ?
> 
> I have attached my globalconfig.out for Fiasco and the l4lx.cfg file
> that I am using, built l4linux for Arm architecture and ARMv7, and is
> using the l4re-snapshot-2015123115 with its ramdisk associated and
> U-boot.

The Linux config would be more valuable here. :)
Is CONFIG_BLK_DEV_RAM enabled?


Adam
-- 
Adam                 adam at os.inf.tu-dresden.de
  Lackorzynski         http://os.inf.tu-dresden.de/~adam/



More information about the l4-hackers mailing list