clang-5.0 is not supported. Please use one of the following versions

Rui Ueyama ruiu at google.com
Mon Jun 5 16:59:13 CEST 2017


I believe the LLD's linker script is now fairly decent that you can expect
it should work in most cases.

On Thu, Jun 1, 2017 at 9:13 PM, Leslie Zhai <lesliezhai at llvm.org.cn> wrote:

> Dear Rui,
>
> 在 2017年06月02日 12:12, Xiang Zhai 写道:
>
> Hi Adam,
>
> Thanks for your reply!
>
> >>* And what about LLVM's lld? I found it is only for GNU binutils' ld
> *>>* https://svn.l4re.org/repos/oc/l4re/trunk/kernel/fiasco/src/kernel.amd64.ld <https://svn.l4re.org/repos/oc/l4re/trunk/kernel/fiasco/src/kernel.amd64.ld>
> *>>* correct?
> *
> > That's a linker script. I never tried with lld. Are linker scripts
> > different with lld?
>
> Please answer this question 有難うございます!
>
>
> Rui, the leader of LLVM's lld, please answer this question, thanks a lot!
>
> PS: New LLD linker for ELF http://llvm.org/devmtg/2016-03/#presentation3
> it said: Linker script support is in progress, correct?
>
> --
> Regards,
> Leslie Zhai - http://www.leetcode.cn
>
>
> --
> Regards,
> Leslie Zhai - a LLVM hacker https://reviews.llvm.org/p/xiangzhai/
>
> --------------7F7B6C23D2428FBDED6F5D23--1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://os.inf.tu-dresden.de/pipermail/l4-hackers/attachments/20170605/0014a275/attachment.html>


More information about the l4-hackers mailing list