Problem with L4re and L4Linux on Qemu/VMware

Daniel (Xiaolong) Wang xiaolongw at
Wed Jun 21 23:25:01 CEST 2017

Hi all,

I’m sorry to bother, again… But I keep getting problems hope you can give me some advice.

I’m trying to test out L4re +L4Linux on X86 and ARM i.MX6. I downloaded the newest l4re-snapshot-2006082114. I built Fiasco with Intel Pentium Pro and Virtualization (did not change anything else).
I built L4re with Pentium Pro type CPU (everything else are default settings). Then I built L4Linux with the L4re builddir. I turned off 64-bit kernel, CPU selected Pentium-Pro, turned off most of the settings as the warning instructed. 

These are the settings of L4Linux that I enabled:

Processor type and features:
	* DMA memory allocation support
	* Processor feature human-readable name
	* Fast CPU feature tests
	* Support for extended X86 platform
	* Single-depth WCHAN output
	* High memory support is OFF
	* Enable bounce buffers
	* X86 architectural random number generator
	* Enable seccomp to safety compute untrusted bytecode
	* Enable the LDT

Power Management and ACPI options:
	* Suspend to RAM and standby
	* device power management core functionality
	* CPU Frequency scaling is OFF
Bus Options:
	* PCI support
	* PCI access mode is Direct

I was able to compile all three parts and build both iso image (for vmware fusion on macOS) and qemu simulator. I first tested hello, hello-cfg, hello-shared, frame buffer-example-x86, all of those works as expected.

However when I tried to build L4Linux-basic and L4Linux-mag-x86. Not of them works.

for L4Linux-mag-x86 the system shows a diagram “system is booting” then hang forever.

for L4Linux-basic the image boot but freeze soon. The screen shows:

	l4cdds: No name given, not starting
	brd: module loaded
	l4cdds: no name given, not starting
	moused: ps/2 mouse device common for all mice
	l4x: Faking dummy RTC
	rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
	rtc_cmos rtc_cmos: only 24-hr supported
	rtc_l4x: l4x-rtc: Could not find ‘rtc’ cap
	rtc_l4x: probe of rtc-l4x failed with error -2
	NET: Registered protocol family 17
	L4IRQ: set irq type of 64 to 1
     	RAMDISK: ext2 filesystem found at block 0
	RAMDISK: Loading 3072KiB [1 disk] into ram disk… done.
	VFS: Mounted root (ext2 filesystem) on device 1:0.
	Freeing unused kernel memory 188K (00494000 - 004c3000)
	Write protecting the kernel text: 2684K
	Write protecting the kernel read-only data 768k
	rodata_test: test data was not read only

	Please press Enter to activate this console. clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x2845e81c5f6, max-idle_ns: 440795276432 ns
	clocksource: Switched to clocksource tsc

Initially I thought it might related RTC so I checked out all Real time clock in L4Linux, but it still the same. Any help would be appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the l4-hackers mailing list