About l4linux debug method

li94575 li94575 at 163.com
Mon Jan 16 10:40:11 CET 2017

At 2017-01-15 19:14:36, "Adam Lackorzynski" <adam at os.inf.tu-dresden.de> wrote:
>On Sun Jan 08, 2017 at 22:54:31 +0800, li94575 wrote:
>> At 2016-12-15 07:45:49, "Adam Lackorzynski" <adam at os.inf.tu-dresden.de> wrote:
>> >
>> >On Wed Dec 14, 2016 at 21:53:48 +0800, li94575 wrote:
>> >> At 2016-12-13 07:01:44, "Adam Lackorzynski" <adam at os.inf.tu-dresden.de> wrote:
>> >> >Hi,
>> >> >
>> >> >On Sun Dec 11, 2016 at 20:45:11 +0800, li94575 wrote:
>> >> >> I have faced a thorny problem, l4linux died occasionally after running into the command line, and there are no errors displayed, pressing the ESC key also cannot enter fiasco jdb-mode. I don't know what caused the problem, can someone provide some methods to help locating this problem?
>> >> >
>> >> >Just do clarify, does it happen right after L4Linux booted in the
>> >> >command line or are you running anything and then, when this is
>> >> >finished, it stops responding?
>> >> >Did ESC work before this happens?
>> >> >Does L4Linux go on running, i.e. is it just serial input that stops
>> >> >working? (Do something like while sleep 1; do date; done)
>> >> >Unfortunately there can be a couple of reasons, so we need to narrow
>> >> >this a bit.
>> >> >
>> >> L4Linux has been dead completely, all peripheral interrupts are no longer responded. The ESC key can work before this happens.
>> >> Actually I have tried starting Android on L4Linux, This phenomenon can appear anywhere in the start-up and running time of Android. Android logcat also has no error tips£¬it seems CPU suddenly stops working.
>> >
>> >Good that you mention Android. Are you passing through hardware devices?
>> >With your description is may be that the Linux is doing something that
>> >it should better not do as it's not in posession of the whole platform,
>> >but it thinks it is.
>> >
>> I have passed through all the necessary hardware devices (fb, input, mmc). We are using l4re--rev58 and l4linux3.10, I wonder if this release itself has some minor problems, and if it is, can you tell me what are the possible bugs, that you have fixed them later.
>Frankly, L4Linux-3.10 is pretty old by now and I'm sure there are fixes
>in the meantime, however it's hard to pinpoint to particular issues.
>One cause of your issues could be DMA, i.e. DMA going wrong and thus
>overwriting stuff in memory. But there could be other reasons too.
>To isolate, did you try to just, for example, use MMC and run heavy
>load on that and see whether this is stable or not?
Thank you very much for your answer.  I have tried to update l4re  to rev67, 
and make some adjustments for l4linux3.10 accordingly, which relates to the
new arm error codes. Now l4linux3.10 can run well, the abnormal crash has 
no longer appeared. I guess it could have been a bug in the rev58 kernel that caused the crash.

More information about the l4-hackers mailing list