exception while running L4linux on raspberry pi 2

Adam Lackorzynski adam at os.inf.tu-dresden.de
Mon Dec 18 00:35:33 CET 2017


On Fri Dec 15, 2017 at 15:09:54 +0530, vmc doe wrote:
>  I tried to build l4+l4Re+l4linux for raspberry pi 2.
> The build was successful, but when I tried to run this in qemu I am getting
> the following error.
> Could you pls help me to fix this error?
> I am new to L4 and L4Re and would like to try out some virtualization
> options with L4 Microkernel.
> Could you pls suggest some initial modules or portions where I can start
> with.
> Regards
> vmc
>   BOOTFS: [1100000-110012e] [C:107000] l4lx.cfg
>   BOOTFS: [1101000-111a4a4] [C:109000] l4re
>   BOOTFS: [111b000-117c718] [C:10b000] ned
>   BOOTFS: [117d000-1576480] [C:10d000] vmlinuz
>   BOOTFS: [1577000-1877000] [C:10f000] ramdisk-arm.rd
> MOE: cmdline: moe rom/l4lx.cfg
> MOE: Starting: rom/ned rom/l4lx.cfg
> MOE: loading 'rom/ned'
> Ned says: Hi World!
> L4Re: unhandled exception: pc=0x1029198 (pfa=205a48)
> L4Re: Global::l4re_aux->ldr_flags=0

Interesting. Is that the default l4lx.cfg? I.e. you're starting L4Linux?
But I think this is earlier. Could you check where in the code the
intruction pointer 0x1029198 is? Use gdb or objdump -ldSC on the 'ned'
binary you find in the build directory.


More information about the l4-hackers mailing list