MIPS Creator CI20 patches (again)

Paul Boddie paul at boddie.org.uk
Wed Dec 20 16:52:45 CET 2017

On Friday 15. December 2017 20.04.11 Paul Boddie wrote:
> I recently looked at the collection of patches accumulated when trying to
> get the CI20 support to a functioning state, and I think I've brought them
> up to date with the latest upstream repository version (r75). In doing so,
> I've also tried to break them up into distinct parcels of functionality so
> that the less interesting or less relevant patches can be ignored.

Unfortunately, I spoke too soon about bringing these patches up to date for 
two reasons. Firstly, I actually tested their application against r75 and 
there were a couple of problems which I think I have fixed now.

However, another problem has emerged when trying to build L4Re. It appears 
that something changed between r72 and r73, and now, when I try and build 
L4Re, I get a linker error as described in the following Debian bug report:


mipsel-linux-gnu-ld: main.o: Can't find matching LO16 reloc against `.text'
for R_MIPS_GOT16 at 0x1f8 in section `mipsel-linux-gnu-ld: BFD (GNU Binutils
for Debian) 2.29.1 internal error, aborting at ../../bfd/bfd.c:866 in

mipsel-linux-gnu-ld: Please report this bug.

Has anything changed in r73 that might affect the structure of generated 
binaries? The same error can also be reproduced in r74 and r75.


P.S. A page describing the patches can be found here:


More information about the l4-hackers mailing list