Assertion failure error in kernel vgic interrupt processing

Adam Lackorzynski adam at os.inf.tu-dresden.de
Tue Apr 10 23:59:58 CEST 2018


On Mon Apr 09, 2018 at 22:26:38 +0800, nico wrote:
> Sorry, the last email did not specify this information. 
> I gave VM1 all the hardware resources, and it used eight cores. VM2 only has
> uart resources (also timer, gic resources), using a single core. I tried to
> give both VM1 and VM2 only the necessary hardware resources( uart, timer, gic),
> and that error won't happen.

Ok, that's interesting. So that means that some of the passed through
hardware is causing this. Would you be able to find out which device is
causing this, by selectively enabling/disabling devices?


Adam

> On 4/9/2018 06:28ï¼ Adam Lackorzynski<adam at os.inf.tu-dresden.de> wroteï¼ 
> 
>     Hi Nico,
> 
>     On Fri Mar 30, 2018 at 10:15:33 +0800, nico wrote:
> 
>         Hi Adam, I'm using an eight-core Cortex-A53 processor. The vm is
>         running 64bit Linux. It is recommended to start two or three vms, that
>         will be easier to reproduce this problem.
> 
> 
>     So, I tried several things but cannot reproduce this issue. I assume
>     this are single-core VMs only? Any hardware passed through?
>     Just trying to narrow it down...



More information about the l4-hackers mailing list