L4Re Build Failure on i386 (Revision 80)

Adam Lackorzynski adam at os.inf.tu-dresden.de
Fri Aug 3 15:36:50 CEST 2018


Hi Paul,

On Fri Aug 03, 2018 at 00:26:45 +0200, Paul Boddie wrote:
> I thought I'd try and get L4Re and the UX variant of Fiasco.OC working again. 
> Various errors with the actual compiler - not typical compilation errors - 
> have previously occurred, but system updates come along every so often and I 
> saw that new revisions of L4Re/Fiasco.OC have also arrived fairly recently.
> 
> Unfortunately, the L4Re build fails with complaints about the linking process. 
> Here is the verbose build output at the point of failure:
> 
>   [fb-drv] ==> Linking fb-drv
> LD_PRELOAD=libgendep.so 
> LD_LIBRARY_PATH=:/home/paulb/L4/UX/src/l4/mybuild/tool/gendep/32:/home/paulb/L4/UX/src/l4/mybuild/tool/gendep 
> GENDEP_TARGET=fb-drv GENDEP_BINARY=ld  GENDEP_BINARY_ALT1=ld 
> /home/paulb/L4/UX/src/l4/tool/bin/l4-bender -t ld -
> Dl4obj=/home/paulb/L4/UX/src/l4/mybuild -Dl4dir=/home/paulb/L4/UX/src/l4 -
> Dgcclibdir="/usr/lib/gcc/i686-linux-gnu/7/ /usr/lib/gcc/i686-linux-
> gnu/7/../../../../i686-linux-gnu/lib/i686-linux-gnu/7/ /usr/lib/gcc/i686-
> linux-gnu/7/../../../../i686-linux-gnu/lib/i386-linux-gnu/ /usr/lib/gcc/i686-
> linux-gnu/7/../../../../i686-linux-gnu/lib/../lib/ /usr/lib/gcc/i686-linux-
> gnu/7/../../../i686-linux-gnu/7/ /usr/lib/gcc/i686-linux-gnu/7/../../../i386-
> linux-gnu/ /usr/lib/gcc/i686-linux-gnu/7/../../../../lib/ /lib/i686-linux-
> gnu/7/ /lib/i386-linux-gnu/ /lib/../lib/ /usr/lib/i686-linux-gnu/7/ 
> /usr/lib/i386-linux-gnu/ /usr/lib/../lib/ /usr/lib/gcc/i686-linux-
> gnu/7/../../../../i686-linux-gnu/lib/ /usr/lib/gcc/i686-linux-gnu/7/../../../ 
> /lib/ /usr/lib/" -Dl4system=x86_gen -Dl4api=l4f -Dlinker="ld -m elf_i386" --
> spec=/home/paulb/L4/UX/src/l4/mk/bid-bender.spec -- -o fb-drv  -MD -MF ./.fb-
> drv.pcs.d -PClibc_support_misc -PClibio-vbus -PCx86emu_int10 -PCx86emu_int10 -
> PCstdlibs -static -gc-sections -Ttext-segment=0x01000000   --defsym 
> __L4_KIP_ADDR__=0xaffff000 --defsym __L4_STACK_ADDR__=0xb0000000 -L 
> /home/paulb/L4/UX/src/l4/mybuild/lib/x86_gen/l4f -L 
> /home/paulb/L4/UX/src/l4/mybuild/lib/x86_gen -L 
> /home/paulb/L4/UX/src/l4/mybuild/lib  --warn-common -Ttext-segment=0x01000000 
> main.o dummy.o splash.o vesa.o  
> ld: section `.note.gnu.property' assigned to non-existent phdr `interp'
> ld: section `.rel.dyn' assigned to non-existent phdr `interp'
> 
> I know that the ldscripts have been changed, but I struggle to see how the 
> above relates to them or whether they are even involved in this particular 
> outcome. Might there be something obviously wrong somewhere in the recent 
> changes?

I also saw this, I currently believe this is due to the latest binutils
(2.31). Are you running this one?



Adam



More information about the l4-hackers mailing list