<html><body><div style="color:#000; background-color:#fff; font-family:times new roman, new york, times, serif;font-size:12pt"><div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "><span>Dear Matthias, </span></div><div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "><span><br></span></div><div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "><span>You are right about the PCI. I checked the configuration and unfortunately the PCI support was not checked. I selected it and I have seen logs for e1000 and PCI support. However, unfortunately now I get kernel panics. This is shown in the following debug outputs at the last 2 lines:</span></div><div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "><span><br></span></div><div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt;
 "><span><div style="font-size: 16px; ">" vmlinuz | Invalid IO-Port access at pc = 006c3e7c port=0x110</div><div style="font-size: 16px; ">vmlinuz | Page fault (non-resolved): pfa=1a8 pc=49475d "</div></span></div><div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "><span><br></span></div><div><span><div>vmlinuz | l4lx_thread_create: Created thread 418 (cpu0) (u:b3000400, v:b3000600, sp:00795ff4)</div><div>vmlinuz | main thread will be 418</div><div>vmlinuz | l4x_register_pointer_section: addr = 00793000 size = 1142784</div><div>vmlinuz | section-with-init: virt: 0x793000 to 0x8a9fff [1116 KiB]</div><div>vmlinuz | section-with-init: Phys: 0x00b04000 to 0x00c1b000, Size:  1142784</div><div>vmlinuz | l4x_linux_startup: thread 418.</div><div>vmlinuz | Main thread running, waiting...</div><div>vmlinuz | main thread: received startup message.</div><div>vmlinuz | l4x_setup_memory: Forcing superpages for main
 memory</div><div>vmlinuz | l4re_global_env: 0xb1007edc</div><div>vmlinuz | Main memory size: 512MB</div><div>vmlinuz |     Main memory: virt: 0xc00000 to 0x20bfffff [524288 KiB]</div><div>vmlinuz |     Main memory: Phys: 0x05800000 to 0x25800000, Size: 536870912</div><div>vmlinuz | Filling lower ptabs...</div><div>vmlinuz | Done (1645 entries).</div><div>vmlinuz | l4x_register_pointer_section: addr = 00793000 size = 1142784</div><div>vmlinuz |             end: virt: 0x793000 to 0x8a9fff [1116 KiB]</div><div>vmlinuz |             end: Phys: 0x00b04000 to 0x00c1b000, Size:  1142784</div><div>vmlinuz | l4x_rd_path: rom/drops-rd.rd</div><div>vmlinuz | Loading: rom/drops-rd.rd</div><div>vmlinuz | INITRD: Size of RAMdisk is 32768KiB</div><div>vmlinuz | RAMdisk from 28c00000 to 2ac00000 [32768KiB]</div><div>vmlinuz | l4lx_thread_create: Created thread 420 (timer.i0)
 (u:b3000800, v:00000000, sp:0082fff8)</div><div>vmlinuz | timer_irq_thread: Starting timer IRQ thread.</div><div>vmlinuz | WARNING: Unknown rdmsr: 00000186 at 0x7cb48a</div><div>vmlinuz | WARNING: Unknown rdmsr: 00000187 at 0x7cb48a</div><div>vmlinuz | WARNING: Unknown wrmsr: 000000c1 at 0x7cb519</div><div>vmlinuz | WARNING: Unknown rdmsr: 000000c1 at 0x7cb52d</div><div>unknown keycodes `empty_aliases(qwerty)', please report to qemu-devel@nongnu.org</div><div>mag     | Input: new keyboard device (src='userdata: 0x6bdc' stream='userdata: 0xccc0')</div><div>mag     |                            bus='i8042' vendor=0x1 product=0x1 version=43841</div><div>vmlinuz | Invalid IO-Port access at pc = 006c3e7c port=0x110</div><div>vmlinuz | Page fault (non-resolved): pfa=1a8 pc=49475d</div><div><br></div><div><br></div></span></div><div style="font-family: 'times new roman',
 'new york', times, serif; font-size: 12pt; "><br></div>  <div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "> <div style="font-family: 'times new roman', 'new york', times, serif; font-size: 12pt; "> <div dir="ltr"> <font size="2" face="Arial"> <hr size="1">  <b><span style="font-weight:bold;">From:</span></b> Matthias Lange <mlange@sec.t-labs.tu-berlin.de><br> <b><span style="font-weight: bold;">To:</span></b> Wajidali Whowe <whowe123@yahoo.com> <br><b><span style="font-weight: bold;">Cc:</span></b> l4-hackers@os.inf.tu-dresden.de <br> <b><span style="font-weight: bold;">Sent:</span></b> Tuesday, August 7, 2012 8:36 AM<br> <b><span style="font-weight: bold;">Subject:</span></b> Re: Ethernet device<br> </font> </div> <br>On Mon, Aug 06, 2012 at 04:47:36PM -0700, Wajidali Whowe wrote:<br>> I prepared another iso image including only l4linux and a small file system prepared by the buildroot (including
 busybox).<br>> the .devs file was exactly the same as the one that I sent before and similarly the .vbus file. The following is the outputs during bootup until fb-drv takes the console: (moreover I wanted to show also dmesg outputs after boot and "lspci" or "mdev -s" outputs after mounting the /proc and /sys", however I could not copy them from qemu or virtual box as I could not activate serial console, please kindly find the screenshots in the respective order for the dmesg outputs" and sorry for the high load of debug outputs...)<br><br>Have you tried the "-serial stdio" option? I cannot see anything PCI or e1000<br>related in the L4Linux log. Can you post the result of "grep PCI .config" and<br>"grep E1000 .config" from your L4Linux config?<br><br>Matthias.<br><br>-- <br>Dipl.-Inf. Matthias Lange <<a ymailto="mailto:mlange@sec.t-labs.tu-berlin.de" href="mailto:mlange@sec.t-labs.tu-berlin.de">mlange@sec.t-labs.tu-berlin.de</a>><br>Security in
 Telecommunications<br>TU Berlin / Telekom Innovation Laboratories<br>Ernst-Reuter-Platz 7, 10587 Berlin<br>Phone: +49 - 30 - 8353 58 553<br>Mobile: +49 - 160 - 587 28 07<br>Web: <a href="http://www.t-labs.tu-berlin.de/sect" target="_blank">http://www.t-labs.tu-berlin.de/sect</a><br><br><br> </div> </div>  </div></body></html>