<div dir="ltr"><div>Hi,</div><div><br></div><div>Sorry if this is not the right forum.</div><div><br></div><div>I'm following </div><div>  <a href="https://os.inf.tu-dresden.de/fiasco/build.html">https://os.inf.tu-dresden.de/fiasco/build.html</a></div>

<div><br></div><div>and i could build fiasco just fine.</div><div><br></div><div>I made a couple of guesses about how to build L4Re because I couldn't find much info:</div><div><br></div><div><div>jack@uv:~/fiasco/src/l4$ mkdir mybuild</div>

<div>jack@uv:~/fiasco/src/l4$ make grub2iso E=hello O=mybuild MODULE_SEARCH_PATH=~/fiasco/src/kernel/fiasco/mybuild/</div><div>Processing entry 'hello'<br></div><div>Could not find 'bootstrap' with path '/home/jack/fiasco/src/kernel/fiasco/mybuild/:/home/jack/fiasco/src/l4/mybuild/bin/amd64_opteron:/home/jack/fiasco/src/l4/mybuild/bin/amd64_opteron/l4f:/home/jack/fiasco/src/l4/mybuild/lib/amd64_opteron:/home/jack/fiasco/src/l4/mybuild/lib/amd64_opteron/l4f'</div>

<div>make: *** [grub2iso] Error 1</div></div><div><br></div><div><div>I find bootstrap.o, but no 'bootstrap':</div></div><div><br></div><div>jack@uv:~/fiasco/src/l4$ find ../kernel/fiasco/mybuild/ -name bootstrap\*</div>

<div>../kernel/fiasco/mybuild/bootstrap.o<br></div><div><br></div><div>I have googled, including this list, but I haven't found the magic combination of words to get the answer.</div><div><br></div><div>Thanks,</div>
<div>
jack.</div><div><br></div><div><br></div><div><br></div><div>This is the kernel globalconfig.out:</div><div><br></div><div><div>#<br></div></div><div><div># Automatically generated file; DO NOT EDIT.</div><div># Fiasco configuration</div>

<div>#</div><div><br></div><div>#</div><div># Target configuration</div><div>#</div><div># CONFIG_IA32 is not set</div><div>CONFIG_AMD64=y</div><div># CONFIG_ARM is not set</div><div>CONFIG_PF_PC=y</div><div>CONFIG_ABI_VF=y</div>

<div>CONFIG_AMD64_K8=y</div><div># CONFIG_AMD64_CORE2 is not set</div><div># CONFIG_AMD64_ATOM is not set</div><div># CONFIG_AMD64_K10 is not set</div><div># CONFIG_CPU_VIRT is not set</div><div>CONFIG_SCHED_APIC=y</div>
<div>
# CONFIG_WORKAROUND_AMD_FPU_LEAK is not set</div><div><br></div><div>#</div><div># Kernel options</div><div>#</div><div>CONFIG_MP=y</div><div>CONFIG_MP_MAX_CPUS=4</div><div>CONFIG_CONTEXT_4K=y</div><div># CONFIG_FINE_GRAINED_CPUTIME is not set</div>

<div>CONFIG_SCHED_FIXED_PRIO=y</div><div># CONFIG_SCHED_WFQ is not set</div><div># CONFIG_SCHED_FP_WFQ is not set</div><div># CONFIG_DISABLE_VIRT_OBJ_SPACE is not set</div><div>CONFIG_VIRT_OBJ_SPACE=y</div><div><br></div>

<div>#</div><div># Debugging</div><div>#</div><div># CONFIG_INLINE is not set</div><div>CONFIG_NDEBUG=y</div><div>CONFIG_NO_FRAME_PTR=y</div><div># CONFIG_STACK_DEPTH is not set</div><div># CONFIG_LIST_ALLOC_SANITY is not set</div>

<div># CONFIG_BEFORE_IRET_SANITY is not set</div><div># CONFIG_IRQ_SPINNER is not set</div><div># CONFIG_WATCHDOG is not set</div><div># CONFIG_SERIAL is not set</div><div># CONFIG_JDB is not set</div><div># CONFIG_POWERSAVE_GETCHAR is not set</div>

<div># CONFIG_WARN_NONE is not set</div><div>CONFIG_WARN_WARNING=y</div><div># CONFIG_WARN_ANY is not set</div><div><br></div><div>#</div><div># Compiling</div><div>#</div><div>CONFIG_CC="gcc"</div><div>CONFIG_CXX="g++"</div>

<div>CONFIG_HOST_CC="gcc"</div><div>CONFIG_HOST_CXX="g++"</div><div># CONFIG_MAINTAINER_MODE is not set</div><div>CONFIG_LABEL=""</div><div>CONFIG_EXPERIMENTAL=y</div><div>CONFIG_BIT64=y</div>

<div>CONFIG_WARN_LEVEL=1</div><div>CONFIG_XARCH="amd64"</div><div>CONFIG_IA32_TARGET="AMD Opteron"</div><div>CONFIG_ABI="vf"</div></div><div><br></div></div>